Page 1 of 1

mpd configuration on macOS

Posted: August 4th, 2020, 2:38 am
by apastuszak
I installed mpd via brew on macOS 10.15.6.

I have an SDAC configured via USB and was trying to see if I could get bit-perfect output on the SDAC, but the only output configuration I can get to work for output is this:

Code: Select all

audio_output {
  type                  "osx"
  name                  "CoreAudio"
  mixer_type            "software"
}
When I look at the sound settings on the Mac using system_profiler SPAudioDataType, I get the following output:

Code: Select all

Audio:

    Devices:

        SDAC :

          Default Output Device: Yes
          Manufacturer: Grace Design
          Output Channels: 2
          Current SampleRate: 44100
          Transport: USB
          Output Source: Default

        Mac mini Speakers:

          Default System Output Device: Yes
          Manufacturer: Apple Inc.
          Output Channels: 2
          Current SampleRate: 48000
          Transport: Built-in
          Output Source: Mac mini Speakers
I tried to setup mpd.conf like this:

Code: Select all

audio_output {
  type                  "osx"
  name                  "SDAC"
  mixer_type            "hardware"
}
but got nowhere.

I kept getting this error:

Code: Select all

Aug 03 22:11 : exception: Failed to enable output "SDAC" (osx); Found no audio device with name 'SDAC'
Is there a way to get bit-perfect playback on OS X?

Re: mpd configuration on macOS

Posted: August 13th, 2020, 8:30 am
by possible
Add this line to your audio_output block:

Code: Select all

device "SDAC"
If this doesn't work, try the device name that is displayed in System Configuration (should be the same, though).

Re: mpd configuration on macOS

Posted: August 13th, 2020, 3:09 pm
by apastuszak
Thank you!

Re: mpd configuration on macOS

Posted: August 13th, 2020, 3:17 pm
by apastuszak
That not work. Picking CoreAudio seems to be the only option that works.

Re: mpd configuration on macOS

Posted: August 13th, 2020, 6:20 pm
by possible
Just so there's no confusion, the configuration should look like this:

Code: Select all

audio_output {
  type	"osx"
  name	"CoreAudio"
  device	"SDAC"
  mixer_type	"software"
}
Note the addition of the device to the name.

Re: mpd configuration on macOS

Posted: August 14th, 2020, 3:05 pm
by apastuszak
Nope, that doesn't work. This is the only thing I have gotten to work:

Code: Select all

audio_output {
  type	"osx"
  name	"CoreAudio"
  mixer_type	"hardware"
}
I don't know if that config will give me bit-perfect output.

Re: mpd configuration on macOS

Posted: October 1st, 2020, 4:59 am
by angelus1969
Hello,

In your output of 'system_profiler SPAudioDataType' I see a space after SDAC. If you copied/pasted the output straight from your terminal, it _could_ be important.....


---
Regards,

Angelo

Re: mpd configuration on macOS

Posted: October 2nd, 2020, 4:18 am
by apastuszak
I’ll give that a try in the morning and see if it works. Thanks!

Re: mpd configuration on macOS

Posted: October 2nd, 2020, 12:16 pm
by apastuszak
Adding the space worked! Thanks!

Re: mpd configuration on macOS

Posted: October 6th, 2020, 7:33 am
by kevinlech
This is really helpful to me, thank you