Page 1 of 1

[solved] MPD downrate Issue

Posted: June 10th, 2021, 7:18 am
by willou

At home, Runeaudio is running on a raspberry Pi 2, wired to a dac cambridge dacmagic 100 with a brand new usb 2.0 cable.
My DAC is supposed to support 192khz but when I read a 192 khz file it detects a 96 khz file.
On runeaudio GUI it indicates that the file is a 192khz file.
when I run cat /proc/asound/card1/pcm0p/sub0/hw_params:

Code: Select all

format: S24_3LE
subformat: STD
channels: 2
rate: 96000 (96000/1)
period_size: 12000
buffer_size: 48000
I tested :
- new usb cable
- add format "192000:*:*" in the right audio_output in mpd.conf
- edit /etc/asound.conf with the rate I want on the right card

No effect, but if I change format in mpd.conf with values under 96khz, it works as expected.

Here's my /etc/mpd.conf :

Code: Select all

state_file      "/var/lib/mpd/mpdstate"
zeroconf_enabled        "yes"
zeroconf_name   "runeaudio"
bind_to_address "/run/mpd.sock"
bind_to_address         "any"
port    "6600"
max_connections         "20"
user    "mpd"
group   "audio"
db_file         "/var/lib/mpd/mpd.db"
sticker_file    "/var/lib/mpd/sticker.sql"
pid_file        "/var/run/mpd/pid"
music_directory         "/mnt/MPD"
playlist_directory      "/var/lib/mpd/playlists"
follow_outside_symlinks         "yes"
follow_inside_symlinks  "yes"
auto_update     "no"
filesystem_charset      "UTF-8"
id3v1_encoding  "UTF-8"
volume_normalization    "no"
audio_buffer_size       "2048"
buffer_before_play      "10%"
gapless_mp3_playback    "yes"
mixer_type      "disabled"

input {
        plugin  "curl"

decoder {
        plugin  "ffmpeg"
        enabled "yes"
replaygain      "off"

audio_output {
        name            "Cambridge AudioDAC100 USB 1"
        type            "alsa"
        device          "hw:1,0"
        auto_resample   "no"
        auto_format     "no"
        format          "192000:*:*"
        enabled         "yes"

audio_output {
        name            "bcm2835 ALSA_2"
        type            "alsa"
        device          "hw:0,0"
        auto_resample   "no"
        auto_format     "no"

audio_output {
        name            "bcm2835 ALSA_1"
        type            "alsa"
        device          "hw:0,0"
        auto_resample   "no"
        auto_format     "no"
"/etc/mpd.conf" 67 lines, 1317 characters
Thank you for your help!


Re: MPD downrate Issue

Posted: June 10th, 2021, 12:00 pm
by max

Re: [solved] MPD downrate Issue

Posted: June 10th, 2021, 1:50 pm
by willou
Thank you for the link but obviously I already checked it before posting my question.
It appeared that my dac was not recognised as a usb audio class 2 but class 1.
First tried to find any conf on alsa or mpd to fix this.
The truth was elsewhere :
On cambridge dacplus 100 you have ton manually switch between class 1 and class 2.
you have to put it on stand by mode, push and hold the source button and click on the poweron button in the same time.

Did that with my dac unplugged form the RPi, plugged it and the result was here, 192khz are played as they are expected

Re: [solved] MPD downrate Issue

Posted: June 10th, 2021, 2:22 pm
by max
> but obviously I already checked it before posting my question

You obviously did not!
If you had, you would have posted the required information mentioned there.