[SOLVED] Make MPD Ignore Cuesheets for Database

Need help with MPD?
Post Reply
mjd119
Posts: 2
Joined: October 20th, 2020, 12:30 am

[SOLVED] Make MPD Ignore Cuesheets for Database

Post by mjd119 »

Since a certain update (not sure which one) when I look through my Music directory in different applications like ncmpcpp and M.A.L.P. in my phone I see a regular 2 different cuesheets. One of them I believe is the original file and the other is one I think that the database generated. This means that when I add a directory to a playlist, I get twice the number of tracks added to the playlist which are sometimes unreadable and have inaccurate track times. I see tracks listed twice per album when I look through the Media Library view on ncmpcpp too. How do I get mpd to completely ignore cuesheets in my directories? I have attempted to disable the cue playlist plugin but I couldn't find anything relevant in the documentation. I believe this problem is specific to mpd and not a specific frontend because I see the same thing with 2 different frontends.
My mpd --version output on Arch Linux is:

Code: Select all

Music Player Daemon 0.22 (0.22)
Copyright 2003-2007 Warren Dukes <warren.dukes@gmail.com>
Copyright 2008-2018 Max Kellermann <max.kellermann@gmail.com>
This is free software; see the source for copying conditions.  There is NO
warranty; not even MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Database plugins:
 simple proxy upnp

Storage plugins:
 local smbclient udisks nfs curl

Neighbor plugins:
 smbclient upnp udisks

Decoders plugins:
 [mad] mp3 mp2
 [mpg123] mp3
 [vorbis] ogg oga
 [oggflac] ogg oga
 [flac] flac
 [opus] opus ogg oga
 [sndfile] wav aiff aif au snd paf iff svx sf voc w64 pvf xi htk caf sd2
 [audiofile] wav au aiff aif
 [dsdiff] dff
 [dsf] dsf
 [hybrid_dsd] m4a
 [faad] aac
 [mpcdec] mpc
 [wavpack] wv
 [modplug] 669 amf ams dbm dfm dsm far it med mdl mod mtm mt2 okt s3m stm ult umx xm
 [mikmod] amf dsm far gdm imf it med mod mtm s3m stm stx ult uni xm
 [sidplay] sid mus str prg P00
 [wildmidi] mid
 [fluidsynth] mid
 [ffmpeg] 16sv 3g2 3gp 4xm 8svx aa3 aac ac3 adx afc aif aifc aiff al alaw amr anim apc ape asf atrac au aud avi avm2 avs bap bfi c93 cak cin cmv cpk daud dct divx dts dv dvd dxa eac3 film flac flc fli fll flx flv g726 gsm gxf iss m1v m2v m2t m2ts m4a m4b m4v mad mj2 mjpeg mjpg mka mkv mlp mm mmf mov mp+ mp1 mp2 mp3 mp4 mpc mpeg mpg mpga mpp mpu mve mvi mxf nc nsv nut nuv oga ogm ogv ogx oma ogg omg opus psp pva qcp qt r3d ra ram rl2 rm rmvb roq rpl rvc shn smk snd sol son spx str swf tak tgi tgq tgv thp ts tsp tta xa xvid uv uv2 vb vid vob voc vp6 vmd wav webm wma wmv wsaud wsvga wv wve rtp:// rtsp:// rtsps://
 [gme] ay gbs gym hes kss nsf nsfe sap spc vgm vgz
 [pcm]

Filters:
 libsamplerate soxr

Tag plugins:
 id3tag

Output plugins:
 shout null fifo pipe alsa ao oss openal solaris pulse jack httpd recorder

Encoder plugins:
 null vorbis opus lame twolame wave flac

Archive plugins:
 [bz2] bz2
 [zzip] zip
 [iso] iso

Input plugins:
 file io_uring archive alsa tidal qobuz curl ffmpeg smbclient nfs mms cdio_paranoia

Playlist plugins:
 extm3u m3u pls xspf asx rss soundcloud flac cue embcue

Protocols:
 file:// alsa:// cdda:// ftp:// ftps:// gopher:// hls+http:// hls+https:// http:// https:// mms:// mmsh:// mmst:// mmsu:// nfs:// qobuz:// rtmp:// rtmpe:// rtmps:// rtmpt:// rtmpte:// rtmpts:// rtp:// rtsp:// rtsps:// scp:// sftp:// smb:// srtp:// tidal://

Other features:
 avahi dbus udisks epoll icu inotify ipv6 systemd tcp un
Last edited by mjd119 on October 27th, 2020, 2:05 am, edited 1 time in total.
max
Forum team
Posts: 1179
Joined: January 15th, 2013, 3:43 pm

Re: Make MPD Ignore Cuesheets for Database

Post by max »

You can easily disable playlist plugins, and that's documented here: https://www.musicpd.org/doc/html/user.h ... st-plugins
farmerdave
Posts: 1
Joined: October 24th, 2020, 7:54 am

Re: Make MPD Ignore Cuesheets for Database

Post by farmerdave »

This is exactly the same issue I am having. Add a directory to a playlist and it adds tracks twice, once for each individual track and once from the cuesheet.
I tried

Code: Select all

# Disable cue sheets
playlist_plugin {
    name "cue"
    enabled "false"
}
and I restarted the mpd service, refreshed the database but the same issue occurs.
mjd119
Posts: 2
Joined: October 20th, 2020, 12:30 am

Re: Make MPD Ignore Cuesheets for Database

Post by mjd119 »

I solved it by adding an .mpdignore file at the root of my Music folder that contains "*.cue" in it. I saw this solution on a forum where a person was trying to ignore files of a different type. Marking this as solved.
max
Forum team
Posts: 1179
Joined: January 15th, 2013, 3:43 pm

Re: [SOLVED] Make MPD Ignore Cuesheets for Database

Post by max »

MPD 0.22.2 will have a fix for this problem.
Next time, write a bug report, that'll make it easier for me to track issues.
Post Reply