exception: Input plugin 'ffmpeg' is unavailable: No protocol

Need help with MPD?
Post Reply
Ff7760
Posts: 2
Joined: August 19th, 2020, 4:46 pm

exception: Input plugin 'ffmpeg' is unavailable: No protocol

Post by Ff7760 »

Hey, I am trying to get rompr running on my windows 10 machine. I don't know much about any of this. I tried to run the command mpd "c:\mpd\mpd.conf". It spits out exception: Input plugin 'FFmpeg' is unavailable: No protocol. I installed FFmpeg and added it as an environment variable. Here is the output of ffmpeg - version (https://pastebin.com/di8RQ1y7) I added the following to the end of my conf file based on (https://www.musicpd.org/news/2011/08/la ... eg-issues/).
input {
plugin "ffmpeg"
enabled "no"
}
From my understanding, this is supposed to disable FFmpeg usage. However, when I run the mpd "c:\mpd\mpd.conf" command it outputs the same error exception: Input plugin 'FFmpeg' is unavailable: No protocol.

Did I implement the disable code incorrectly? Is there another way around this error?

Output of mpd "c:\mpd\mpd.conf" (https://pastebin.com/nFQDuhKy)

My conf file (https://pastebin.com/Bdg3PLHT)

I am using this guide to get things running (https://fatg3erman.github.io/RompR/Inst ... on-Windows)

I am trying to do all this so I can see all the unavailable songs on my playlist without having to scroll through all of them. If you know of an easier way please let me know. Thank you for your time.

EDIT: I changed my disable code to disable the input plugin instead of the decoder plugin
Last edited by Ff7760 on August 21st, 2020, 3:43 pm, edited 2 times in total.
max
Forum team
Posts: 1139
Joined: January 15th, 2013, 3:43 pm

Re: exception: Input plugin 'ffmpeg' is unavailable: No protocol

Post by max »

Obey the message: it is about the FFmpeg input plugin, but you tried to disable the FFmpeg decoder plugin.
Ff7760
Posts: 2
Joined: August 19th, 2020, 4:46 pm

Re: exception: Input plugin 'ffmpeg' is unavailable: No protocol

Post by Ff7760 »

max wrote: August 20th, 2020, 10:06 am Obey the message: it is about the FFmpeg input plugin, but you tried to disable the FFmpeg decoder plugin.
I feel dumb. Thank you for the lead!
Post Reply