Connect to SMB client

Need help with MPD?
Post Reply
Posts: 6
Joined: May 17th, 2020, 6:39 pm

Connect to SMB client

Post by langrock »

Figured it out after fiddling with it some more. The problem was the database entry, which pointed to the server. Using the "simple" plugin, and using a local file for the database and cache_directory, myMPD is now starting to populate the database from the SMB source! I had to run 'mpc update' to trigger this. From another post, it seems that MPD won't be able to access a share that has access restrictions.

Problem statement:


This may be a solved issue, but I don't seem to be able to browse the forum to look for an answer ...

I am trying to configure MPD to use music stored on a NAS (WD My Cloud), which is accessible through SMB. Initially, the music volume on the NAS was password protected. I followed the Satellite Setup procedure and received 'Connection refused' messages. I thought this may be due to the access privileges, even though I had specified both username and password in the music_directory variable.

Either way, making the Music share world-readable (public) did not change that problem. I can connect to the share without a problem from macOS. Both the NAS and the Raspberry Pi running MPD are on the same network and I can ping the NAS from the terminal when logged into the Pi.

Everything else seems to work ... mympd is connecting to mpd and so is MaximumMPD from an iOS device. Of course, they all through that same connection refused error I get from the command line using mpc.

exception: Failed to connect to remote MPD ''
exception: nested: Connection refused

Does anybody have an idea what else I could try or how to troubleshoot this? Below is my mpd.conf

music_directory "smb://"
playlist_directory "/mnt/dietpi_userdata/Music"
log_file "/var/log/mpd/mpd.log"
pid_file "/run/mpd/pid"
state_file "/mnt/dietpi_userdata/.mpd_cache/state"
sticker_file "/mnt/dietpi_userdata/.mpd_cache/sticker.sql"

database {
plugin "proxy"
host ""

neighbors {
plugin "smbclient"

#user "mpd" # Set via systemd unit to preserve supplementary group permissions i.e. "dietpi" group

bind_to_address "/run/mpd/socket"
bind_to_address ""

log_level "default"
metadata_to_use "artist,album,title,track,name,genre,date"
auto_update "yes"

zeroconf_enabled "yes"
zeroconf_name "DietPi MPD"

input {
plugin "curl"

connection_timeout "30"
max_connections "4"

filesystem_charset "UTF-8"
audio_buffer_size "2048"

audio_output {
type "alsa"
name "DietPi Alsa"
device "hw:1,0"
format "44100:16:2"
mixer_type "hardware"

# Disable DSD DoP MPD 0.19
dop "no"
Post Reply