Problems compiling MPD on Lubuntu

Need help with MPD?
Post Reply
conta
Posts: 99
Joined: October 31st, 2013, 4:59 pm

Problems compiling MPD on Lubuntu

Post by conta » November 2nd, 2018, 4:27 pm

Hi there,

first thanks a lot for your efforts about MPD and the actual new version 0.21!

But second - it seems to be difficult to compile the new version on Lubuntu. Sorry about the stupid question... :?

The former versions of MPD i usually compiled with the following lines:

Code: Select all

./configure --sysconfdir=/home/xyz/.mpd --enable-soxr
make
And it is clear, that this does not work out - the file "./configure" is not present any more.
Also "./autogen.sh" does not work, it tells me:

Code: Select all

aclocal: error: 'configure.ac' is required
Again sorry about my restricted linux-knowledge, but could somebody please tell me, how to compile the new MPD?

skidoo
Posts: 165
Joined: April 28th, 2013, 10:06 pm
Location: Western Germany

Re: Problems compiling MPD on Lubuntu

Post by skidoo » November 2nd, 2018, 6:13 pm

https://raw.githubusercontent.com/Music ... v0.21/NEWS

Code: Select all

build with Meson instead of autotools

conta
Posts: 99
Joined: October 31st, 2013, 4:59 pm

Re: Problems compiling MPD on Lubuntu

Post by conta » November 2nd, 2018, 8:36 pm

Thanks skidoo,

hmm, ja, hurray... never heard of this :?

So i installed Python3 and Ninja. I learnd, that i have to run:

Code: Select all

meson builddir
to start the build process.
When i run this command, i get the following error:

Code: Select all

Meson encountered an error in file meson_options.txt, line 5, column 0:
Unknown type feature.
So is there maybe something wrong with the file "meson_options.txt"?
Line 5 looks like that:

Code: Select all

option('syslog', type: 'feature', description: 'syslog support')

max
Forum team
Posts: 886
Joined: January 15th, 2013, 3:43 pm

Re: Problems compiling MPD on Lubuntu

Post by max » November 3rd, 2018, 6:40 am

Your Meson version is too old. Documentation says MPD needs at least version 0.47.
https://www.musicpd.org/doc/html/user.h ... rom-source

skidoo
Posts: 165
Joined: April 28th, 2013, 10:06 pm
Location: Western Germany

Re: Problems compiling MPD on Lubuntu

Post by skidoo » November 3rd, 2018, 3:00 pm

Same config (x64) here. Upgrade to Lubuntu 18.10 and apply workaround for boost 1.67 next’ is not a member of ‘boost’ build error.

https://github.com/skidoo23/MPD/commit/ ... e58daf2151

Post Reply