Page 1 of 1

Full Duplex mixer problem

Posted: January 22nd, 2017, 9:45 am
by mjubes
This is for a Raspberry Pi, using ALSA and MPD v19 with I2S 48k 24 bit both on input and output.

I want to playback two MPD streams using the ALSA mixer, while at the same time capturing on another (just one) I2S channel (i.e full duplex)
I am using more than one instance of MPD with different mpd.conf files.

(1) I can playback and capture two different streams at the same time no proble (i.e. I2S duplex) with the following entries in asound.conf:

pcm. !default {
type hw
card 0
}
ctl. !default {
type hw
card 0
}

(2) However this only allows me only one output stream at a time, i.e. no mixing. However, changing this to (to enable an output mixer):

pcm. !default {
type plug
slave.pcm "dmix"
}
ctl. !default {
type hw
card 0
}
Allows me to mix two or more outputs together into a single I2S output stream. However capture doesn't work now, it just returns a loud hiss. Something perhaps to do with wrongly defined bit formats I imagine?


(3) Changing the above to the following, produces the same results, i,.e. output mixing working and capture hiss still there.

pcm. !default {
type asym
playback.pcm "dmix"
capture.pcm "dsnoop"
}
ctl. !default {
type hw
card 0
}

Anything else I could try?
thanks in advance