MPD build dependency for libmikmod2-dev

Need help with MPD?
Post Reply
rhoering
Posts: 68
Joined: August 11th, 2014, 2:12 pm

MPD build dependency for libmikmod2-dev

Post by rhoering »

Just checking if others are seeing this with the latest Debian Jessie.
Note, selecting 'libmikmod-dev' instead of 'libmikmod2-dev'
I also got two "Unable to locate packages" which I need to run down.

root@hostname:/home/blahblah# sudo apt-get install g++ automake autoconf \
> libmad0-dev libmpg123-dev libid3tag0-dev \
> libflac-dev libvorbis-dev libopus-dev \
> libadplug-dev libaudiofile-dev libsndfile1-dev libfaad-dev \
> libfluidsynth-dev libgme-dev libmikmod2-dev libmodplug-dev \
> libmpcdec-dev libwavpack-dev libwildmidi-dev \
> libsidplay2-dev libsidutils-dev libresid-builder-dev \
> libavcodec-dev libavformat-dev \
> libmp3lame-dev \
> libsamplerate0-dev \
> libbz2-dev libcdio-paranoia-dev libiso9660-dev libmms-dev \
libasound2-dev libao-dev libjack-jackd2-dev libopenal-dev \
libpulse-dev libroar-dev libshout3-dev \
> libzzip-dev \
> libcurl4-gnutls-dev libyajl-dev \
> libasound2-dev libao-dev libjack-jackd2-dev libopenal-dev \
> libpulse-dev libroar-dev libshout3-dev \
> libmpdclient-dev \
> libavahi-client-dev \
> libsqlite3-dev \
> libsystemd-daemon-dev libwrap0-dev \
> libcppunit-dev xmlto \
> libboost-dev \
> libglib2.0-dev \
> libupnp-dev \ libexpat1-dev \ libsmbclient-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libmikmod-dev' instead of 'libmikmod2-dev'
E: Unable to locate package libexpat1-dev
E: Unable to locate package libsmbclient-dev

rhoering
Posts: 68
Joined: August 11th, 2014, 2:12 pm

Re: MPD build dependency for libmikmod2-dev

Post by rhoering »

Side note:

Rerunning the above list of installs WITHOUT libexpat1-dev and libsmbclient-dev completed just fine.

Then I ran "apt-get install libexpat1-dev" by itself and it installed. Same for "apt-get install libsmbclient-dev".

Post Reply