No sound

Gnome Music Player Client - Support forum for the oldest GTK+ based Client.
Website: http://gmpclient.org/
Post Reply
frisket
Posts: 2
Joined: April 10th, 2018, 9:07 pm

No sound

Post by frisket » April 10th, 2018, 9:23 pm

I am getting tantalizingly close to getting MPD and GMPC working but while I could see a track playing yesterday, I get no audio. Today I get the error MPD reported an error: 'Failed to open audio output'.

Server (elsewhere in the house) runs Mint 18 and MPD started as a system service reading from my Music directory.

Client: my laptop, also Mint, running GMPC and connecting to the MPD server. I can see all my music, so the connection at least is working.

$ aplay -l on the server says I have
card 0: Intel [HDA Intel], device 0: AD1983 Analog [AD1983 Analog]
(although why that would matter at all is puzzling: it's a server, it doesn't even need a sound card, surely). I have no idea if this is an ALSA device or a Pulseaudio device (mpd.conf on the server is configured for pulse).

$ aplay -l on the laptop says much more:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0

No idea why it needs all these. Equally nothing to say what audio driver it uses. Rhythmbox plays locally-stored MP3s just fine, so I know sound is capable of working.

On the server, mpd.log says
Apr 10 21:57 : zeroconf: No global port, disabling zeroconf
Apr 10 22:17 : errno: Failed to open "/var/lib/mpd/playlists/Favorites.m3u": No such file or directory
Apr 10 22:17 : playlist: No such playlist
Apr 10 22:18 : pulse_output: Failed to open "My Pulse Device" [pulse]: failed to connect: Connection refused
Apr 10 22:18 : output: Failed to open audio output
Apr 10 22:18 : player: problems opening audio device while playing "Vivaldi/Concerti - Baroque Festival Orchestra/15.Violin Concerto in A minor - Presto.mp3"
Apr 10 22:18 : player: played "Vivaldi/Concerti - Baroque Festival Orchestra/15.Violin Concerto in A minor - Presto.mp3"
Apr 10 22:18 : pulse_output: Failed to open "My Pulse Device" [pulse]: failed to connect: Connection refused
Apr 10 22:18 : output: Failed to open audio output

I don't understand why the server needs to do this: surely all it has to do is serve a stream to the client, and the client opens an audio output?

max
Forum team
Posts: 755
Joined: January 15th, 2013, 3:43 pm

Re: No sound

Post by max » April 11th, 2018, 7:03 am

I think you have a heavy misunderstanding of what MPD is. MPD clients do not receive an audio stream. All they do is send control commands to MPD. The machine where you installed MPD is supposed to have the sound card and the speakers.

frisket
Posts: 2
Joined: April 10th, 2018, 9:07 pm

Re: No sound

Post by frisket » April 12th, 2018, 7:43 pm

Aha. Yes, I have grossly misunderstood what MPD is, it seems.

I wanted one copy of my music, served from a server, playable on any client in the house.

What MPD seems to offer is to play the music in a single location (the server, in the server room) controllable from any client. This doesn't seem to be a useful proposition for my requirement.

That you for the explanation.

Post Reply