Upnp plugin not playing

Discuss client development (or even MPD development if you feel so inclined), ask questions about the client libs, MPD feature requests from client developers, etc...
Post Reply
rickx
Posts: 4
Joined: May 4th, 2014, 9:25 pm

Upnp plugin not playing

Post by rickx » May 4th, 2014, 9:39 pm

Hallo,
I'm interested in mpd's upnp capabilities, so I compiled it on a raspberry pi (running volumio/debian).
The browsing of my upnp server (through xbmc) works nicely, but when it comes to play...nothing.
This is what the log says when trying to play something

Code: Select all

May 04 23:19 : client: [7] opened from 127.0.0.1:44571
May 04 23:19 : client: [7] process command "status"
May 04 23:19 : client: [7] command returned 0
May 04 23:19 : client: [7] process command "add "XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rumour Has It""
May 04 23:19 : client: [7] command returned 0
May 04 23:19 : client: [7] process command "play 3"
May 04 23:19 : playlist: play 3:"XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rumour Has It"
May 04 23:19 : client: [7] command returned 0
May 04 23:19 : decoder_thread: probing plugin ffmpeg
May 04 23:19 : playlist: queue song 0:"XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : client: [7] process command "close"
May 04 23:19 : client: [7] command returned 3
May 04 23:19 : client: [7] closed
May 04 23:19 : player: played "XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rumour Has It"
May 04 23:19 : playlist: play 0:"XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : playlist: queue song 1:"XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : decoder_thread: probing plugin ffmpeg
May 04 23:19 : player: played "XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : playlist: play 1:"XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : playlist: queue song 2:"XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rolling In the Deep"
May 04 23:19 : decoder_thread: probing plugin ffmpeg
May 04 23:19 : player: played "XBMC (xbmuntu)/Music Library/Artisti/Adele/Single/Skyfall"
May 04 23:19 : playlist: play 2:"XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rolling In the Deep"
May 04 23:19 : playlist: queue song 3:"XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rumour Has It"
May 04 23:19 : decoder_thread: probing plugin ffmpeg
May 04 23:19 : player: played "XBMC (xbmuntu)/Music Library/Artisti/Adele/21/Rolling In the Deep"
May 04 23:19 : playlist: stop
The log says "played" but actually that's more an attempt...it does not play any of the songs and all this log block is written in less than a second. So my guess is the file extensions get cut somewhere along the way and that could be the reason. But I could also be wrong.
thanks in advance for any help.

scarnot
Posts: 3
Joined: June 12th, 2014, 1:55 pm

Re: Upnp plugin not playing

Post by scarnot » June 12th, 2014, 2:05 pm

rickx wrote:Hallo,
I'm interested in mpd's upnp capabilities, so I compiled it on a raspberry pi (running volumio/debian).
The browsing of my upnp server (through xbmc) works nicely, but when it comes to play...nothing.
This is what the log says when trying to play something

The log says "played" but actually that's more an attempt...it does not play any of the songs and all this log block is written in less than a second. So my guess is the file extensions get cut somewhere along the way and that could be the reason. But I could also be wrong.
thanks in advance for any help.
Just to make sure, you compiled MPD with the UPnP database plugin enabled, you are using XBMC as an UPnP Content Directory, and you are controlling MPD with some MPD client ?

rickx
Posts: 4
Joined: May 4th, 2014, 9:25 pm

Re: Upnp plugin not playing

Post by rickx » June 12th, 2014, 4:17 pm

Hallo scarnot,
yes, at the time of that writing (1 month ago) that was the scenario: mpd using volumio's web-UI (on raspberry pi), xbmc with its media offered through upnp on another pc.
In the meantime I upgraded volumio. Now it has upnp enabled by default, it's version 0.18.10...
Actually it works now, although there's still a strange behavior regarding file extensions: mp3 files are shown as m3u (but played correctly). I did not investigate enough to know if it's mpd or the webUI causing that.

scarnot
Posts: 3
Joined: June 12th, 2014, 1:55 pm

Re: Upnp plugin not playing

Post by scarnot » June 12th, 2014, 4:50 pm

Thanks, I am going to try it. I was wondering if you were using the merged UPnP plugin version from the MPD git or the original one from http://www.lesbonscomptes.com/pages/mpd-upnp.html.

rickx
Posts: 4
Joined: May 4th, 2014, 9:25 pm

Re: Upnp plugin not playing

Post by rickx » June 12th, 2014, 7:47 pm

No, the original did not work at all. The rewritten one from git which I tried came a bit nearer (I could navigate content...sort of).
scarnot wrote:Thanks, I am going to try it. I was wondering if you were using the merged UPnP plugin version from the MPD git or the original one from http://www.lesbonscomptes.com/pages/mpd-upnp.html.

rickx
Posts: 4
Joined: May 4th, 2014, 9:25 pm

Re: Upnp plugin not playing

Post by rickx » June 13th, 2014, 4:46 am

sorry: I just discovered djmount, That's responsible for mounting upnp media in volumio, not mpd itself!!
Not the cleanest solution maybe, but it works...

scarnot
Posts: 3
Joined: June 12th, 2014, 1:55 pm

Re: Upnp plugin not playing

Post by scarnot » June 13th, 2014, 8:21 am

rickx wrote:No, the original did not work at all. The rewritten one from git which I tried came a bit nearer (I could navigate content...sort of).
scarnot wrote:Thanks, I am going to try it. I was wondering if you were using the merged UPnP plugin version from the MPD git or the original one from http://www.lesbonscomptes.com/pages/mpd-upnp.html.
Strange, I just tried the original one (no build needed...), and it works fine for me, I just installed the package, changed mpd.conf, and I can browse, add songs, and play. Did a quick test using mpc, but I can't see why this would not work with another client. This was on Raspbian though, because this is what I have at hand.

Post Reply