Search found 1254 matches

by max
February 12th, 2021, 3:28 pm
Forum: Tips, Tricks, and Hacks
Topic: MPD + PulseAudio = Jerky sound ?
Replies: 11
Views: 2300

Re: MPD + PulseAudio = Jerky sound ?

MPD 0.21.5 is very old and unsupported. You should upgrade to the latest version before you report problems.
by max
February 11th, 2021, 7:37 pm
Forum: Tips, Tricks, and Hacks
Topic: MPD + PulseAudio = Jerky sound ?
Replies: 11
Views: 2300

Re: MPD + PulseAudio = Jerky sound ?

jean_bruder wrote: February 11th, 2021, 7:16 pm Is MPD known not to work properly on certain types of hardware (Rock64)?
No. MPD has extremely low hardware requirements, and Rock64 is overpowered by several orders of magnitude.

To analyze your problem, more information is necessary. See https://www.musicpd.org/help/
by max
February 11th, 2021, 5:16 pm
Forum: General Discussion
Topic: MPD and Tags
Replies: 21
Views: 11637

Re: MPD and Tags

TSOC is not part of the ID3 specification, it's a proprietary Apple extension.
TMED, TFLT, TOWN sound rather useless.
by max
February 10th, 2021, 5:43 am
Forum: Help
Topic: No audio produced by any mpd client
Replies: 7
Views: 1127

Re: No audio produced by any mpd client

No, you did not actually answer my question. Neither ncmpc nor Ymuse are capable of receiving streams. They are just MPD clients, which means they control playback, but they do not "play" music. MPD is the music player, not ncmpc or Ymuse. See https://www.musicpd.org/doc/html/user.html#i-can-t-hear-...
by max
February 9th, 2021, 7:25 pm
Forum: Help
Topic: No audio produced by any mpd client
Replies: 7
Views: 1127

Re: No audio produced by any mpd client

You configured a streaming output ("httpd"). Which software are you using to receive and actually play this stream?
by max
February 7th, 2021, 7:59 pm
Forum: Help
Topic: Playlist does not play
Replies: 3
Views: 564

Re: Playlist does not play

You're probably a sad Debian user. Debian ships outdated and known-buggy package versions and they call it "stable". That gives me lots of support headaches.
Here you can get more up-to-date MPD versions: https://www.musicpd.org/download-unoff-debian/
by max
February 7th, 2021, 7:30 pm
Forum: General Discussion
Topic: MPD and Tags
Replies: 21
Views: 11637

Re: MPD and Tags

Your quick fix looks correct. Sometimes, computer stuff is as easy as it seems. (Sometimes, not.)
by max
February 7th, 2021, 9:06 am
Forum: General Discussion
Topic: MPD and Tags
Replies: 21
Views: 11637

Re: MPD and Tags

v.kostas wrote: February 6th, 2021, 9:11 pm If some simple instructions are given, a contribution would be feasible in git.
It really looks like TPE3 should be mapped to conductor and not performer, but let's discuss your code on GitHub. Send a PR.
by max
February 7th, 2021, 7:15 am
Forum: Help
Topic: Playlist does not play
Replies: 3
Views: 564

Re: Playlist does not play

Your MPD version is very old and unsupported.
But it looks like your M3U contains absolute paths. Can you confirm that there exists a directory named "Herbie Hancock" at the very root of your Linux installation?
by max
February 6th, 2021, 12:35 pm
Forum: Help
Topic: volume resets to 40% after reboot
Replies: 3
Views: 536

Re: volume resets to 40% after reboot

Then you should ask the Moode developer for support.
Moode is not supported by the MPD project.
by max
February 4th, 2021, 3:38 pm
Forum: Help
Topic: DTS-WAV files
Replies: 2
Views: 474

Re: DTS-WAV files

You can't overwrite the format. But you could use stickers to mark those files which you believe contain DTS encoded into standard PCM.
by max
February 4th, 2021, 12:40 pm
Forum: Help
Topic: volume resets to 40% after reboot
Replies: 3
Views: 536

Re: volume resets to 40% after reboot

Is this question about MPD or about the operating system you chose to install on your Pi?
by max
February 3rd, 2021, 4:04 pm
Forum: Help
Topic: MPD does not play flac, Failed to open "My ALSA Device"
Replies: 2
Views: 499

Re: MPD does not play flac, Failed to open "My ALSA Device"

How did you install MPD? Which version?
How do you launch MPD?
Does MPD have permission to access the sound devices?
by max
February 1st, 2021, 7:41 am
Forum: General Discussion
Topic: MPD overwriting radio metadata
Replies: 3
Views: 854

Re: MPD overwriting radio metadata

MPD will always pick up tags from the radio stream, and this stream has a "Icy-Name" response header with a rather dull value ("icy-name: franceinfo-midfi.mp3").
But what shouldn't happen is that MPD "forgets" all the other tag values. Write a bug report, and I'll investigate it.
by max
January 15th, 2021, 6:19 am
Forum: Help
Topic: Speed up mpd start on rpi zero w
Replies: 11
Views: 1865

Re: Speed up mpd start on rpi zero w

The line where MPD opens its configuration file: openat(AT_FDCWD, "/etc/mpd.conf", O_RDONLY|O_NOCTTY|O_LARGEFILE|O_CLOEXEC) = 3 .. is the point where MPD takes over control. Before that, no MPD code runs, it's all the ld.so loading shared libraries. The static build is mostly about the libraries MPD...
by max
January 14th, 2021, 4:27 am
Forum: Help
Topic: Speed up mpd start on rpi zero w
Replies: 11
Views: 1865

Re: Speed up mpd start on rpi zero w

This has reduced the startup time by 2 seconds, that's a lot! To reduce this further, you need to reduce the number of library dependencies further. For example, it loads libharfbuzz, which is a text layout library, but MPD doesn't render any text ... this is probably pulled in by FFmpeg. You can ei...
by max
January 13th, 2021, 7:43 am
Forum: Help
Topic: Speed up mpd start on rpi zero w
Replies: 11
Views: 1865

Re: Speed up mpd start on rpi zero w

It needs 0.4 seconds just to find one single shared library. Your strace suggests that your library search path is extremely long. Did you do any special hacks to make it that long? For example, set LD_LIBRARY_PATH?
by max
January 12th, 2021, 6:44 pm
Forum: Help
Topic: websocket disconnected
Replies: 1
Views: 536

Re: websocket disconnected

This is not a MPD problem, because MPD cannot do anything with WebSockets.