Search found 1254 matches

by max
February 22nd, 2021, 11:49 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

No. This must never happen, this must be a bug in Meson. Or a buggy patch applied to Meson by the Yocto-Meson package. Consult Yocto support.
by max
February 22nd, 2021, 8:23 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

That's wrong. This violates Meson's documentation. How did this illegal value end up there?

See https://mesonbuild.com/Reference-tables ... stem-names
by max
February 22nd, 2021, 5:13 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

It checks for sqlite and libupnp: Run-time dependency sqlite3 found: YES 3.29.0 Run-time dependency libupnp found: YES 1.8.4 But between those two, it *should* check for libsystemd, but it doesn't. From the meson.build, there is exactly one reason why it would skip that check (and not even print a m...
by max
February 20th, 2021, 4:25 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

What does "mpd --version" print?
Does it show libsystemd being detected in the log.configure?
by max
February 20th, 2021, 12:05 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

Did you build MPD without libsystemd?
by max
February 20th, 2021, 7:49 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2537

Re: MPD >0.21 with yocto

Doesn't seem to do what trick? What is the remaining problem?
by max
February 18th, 2021, 4:26 pm
Forum: Help
Topic: help me troubleshoot - ALSA, MPD or USB preamp issue
Replies: 1
Views: 1057

Re: help me troubleshoot - ALSA, MPD or USB preamp issue

I don't think anybody here can help you. This problem has nothing to do with MPD. The kernel has decided that the sound device is gone - maybe because it thinks it has been unplugged. Check the kernel logs for details. Different programs can make a difference if you configured to access the hardware...
by max
February 18th, 2021, 7:51 am
Forum: General Discussion
Topic: Congrats Snapcast support
Replies: 1
Views: 1354

Re: Congrats Snapcast support

Even if it's still experimental - you're welcome to report problems like that Android problem on GitHub.
by max
February 17th, 2021, 11:05 pm
Forum: NCMPC
Topic: Exit when MPD shutdown
Replies: 1
Views: 2266

Re: Exit when MPD shutdown

No. Write bug report.
by max
February 17th, 2021, 12:45 pm
Forum: General Discussion
Topic: Forum search not working
Replies: 1
Views: 1231

Re: Forum search not working

It's broken, but I don't know why and I have no time to fight with phpBB. I was thinking about shutting the forum down and move all discussions to GitHub. I never wanted a forum, but the guy who demanded one and set it up many years ago is gone. Now everything's up to me. Sigh.
by max
February 17th, 2021, 12:43 pm
Forum: Help
Topic: Playing zip archives outside music database using local socket
Replies: 2
Views: 1185

Re: Playing zip archives outside music database using local socket

I think archives outside of the database/music_directory are not implemented (properly). Implementing that would be a good idea. Can you write a GitHub issue?
by max
February 16th, 2021, 3:16 pm
Forum: Developers' Corner
Topic: can't figure out search/find request format
Replies: 1
Views: 1141

Re: can't figure out search/find request format

Let's look at this example: search (artist contains "red" ) This is a "search" command with 4 parameters (separated by spaces): "(artist" "contains" "red" ")" This doesn't look right, does it? The filter expression must be exactly one argument (see https://www.musicpd.org/doc/html/protocol.html#filt...
by max
February 16th, 2021, 12:20 pm
Forum: Help
Topic: HTTP Stream: Tracks switch every second
Replies: 5
Views: 1024

Re: HTTP Stream: Tracks switch every second

So your instructions above were wrong. They were very specific, but they were wrong. That's not helpful. It's a waste of time. Now we need to start from scratch analyzing your problem.
by max
February 16th, 2021, 6:10 am
Forum: Tips, Tricks, and Hacks
Topic: MPD + PulseAudio = Jerky sound ?
Replies: 11
Views: 2298

Re: MPD + PulseAudio = Jerky sound ?

What was the point of this "Group" setting? Why tell MPD to change the group (and drop all other supplementary groups)? Of course, this is broken.
by max
February 16th, 2021, 6:08 am
Forum: Help
Topic: HTTP Stream: Tracks switch every second
Replies: 5
Views: 1024

Re: HTTP Stream: Tracks switch every second

"mpc play" re-starts playback at whatever song is the current song. This is not the proper way to resume playback after "pause". You can use "mpc toggle" to resume playback properly.
by max
February 15th, 2021, 11:25 am
Forum: Help
Topic: HTTP Stream: Tracks switch every second
Replies: 5
Views: 1024

Re: HTTP Stream: Tracks switch every second

I don't understand. Can you rephrase, and be more specific? Maybe a verbose log would help.
by max
February 15th, 2021, 6:29 am
Forum: Help
Topic: No audio produced by any mpd client
Replies: 7
Views: 1115

Re: No audio produced by any mpd client

Sorry, I have no idea of PulseAudio. I don't like it, and I can't help with it.
by max
February 14th, 2021, 8:52 am
Forum: Help
Topic: MPD won't play tracks, stops at 1 second
Replies: 2
Views: 648

Re: MPD won't play tracks, stops at 1 second

You're using the default ALSA device. Try explicitly specifying a "hw:" device.
by max
February 13th, 2021, 3:42 pm
Forum: Help
Topic: No audio produced by any mpd client
Replies: 7
Views: 1115

Re: No audio produced by any mpd client

At this point I only want it to work such that the mpd server computer will serve the music to an mpc client computer, such that I can browse and manage the songs being played on that client computer using something like mpc, and hear the music on that client computer. This is not how MPD works. Di...
by max
February 13th, 2021, 3:40 pm
Forum: Developers' Corner
Topic: How to authenticate client using libmpdclient?
Replies: 2
Views: 467

Re: How to authenticate client using libmpdclient?

You need to connect via local socket.
If you develop a client, never hard-code "127.0.0.1" and 6600. Just pass NULL and 0. This way, libmpdclient uses proper defaults and users can override them by setting the environment variables MPD_HOST and MPD_PORT.