Search found 1245 matches

by max
March 17th, 2021, 5:25 am
Forum: Help
Topic: Mpd on MoodeAudio: command for add current song to playlist ??? Help !!!
Replies: 5
Views: 878

Re: Mpd on MoodeAudio: command for add current song to playlist ??? Help !!!

You could use Python-MPD2: https://python-mpd2.readthedocs.io/en/latest/

from mpd import MPDClient
client = MPDClient()
client.connect("localhost", 6600)
song = client.currentsong()
if song: client.playlistadd('the_playlist_name', song['file'])

Simple, isn't it?
by max
March 16th, 2021, 8:01 pm
Forum: Help
Topic: Mpd on MoodeAudio: command for add current song to playlist ??? Help !!!
Replies: 5
Views: 878

Re: Mpd on MoodeAudio: command for add current song to playlist ??? Help !!!

mpc has no command to add something to a stored playlist. Adding this feature would be easy if you know some C. MPD has commands to do it, and libmpdclient (the C library used by mpc) has it as well - it just needs to be wired to a mpc command.
But you could also write a small Python script to do it.
by max
March 9th, 2021, 10:02 am
Forum: Help
Topic: Use database from Upnp and local disc
Replies: 1
Views: 485

Re: Use database from Upnp and local disc

That is not yet possible - welcome to write a feature request on GitHub!
Right now, you can only combine ("mount") several "simple" plugins together (with different storages, e.g. local hard disk, nfs, usb stick etc.).
by max
March 2nd, 2021, 12:05 pm
Forum: Help
Topic: MPD not playing most (but not all) streams anymore
Replies: 6
Views: 552

Re: MPD not playing most (but not all) streams anymore

No, I have no idea what may cause this. I never use any ALSA plugins, I always use "hw" devices directly. As I already mentioned here, this reduces CPU usage and increases quality - it's a win-win.
by max
March 2nd, 2021, 5:55 am
Forum: Help
Topic: MPD not playing most (but not all) streams anymore
Replies: 6
Views: 552

Re: MPD not playing most (but not all) streams anymore

Everything looks fine in your log. If I understood you correctly, then only the first stream is audible. The one thing that is different in the first stream is that its sample rate is 32 kHz, the others have 44.1 kHz. 32 kHz is unusual, and it's unusual that a "standard" sample rate like 44.1 kHz fa...
by max
February 28th, 2021, 1:42 pm
Forum: Help
Topic: MPD not playing most (but not all) streams anymore
Replies: 6
Views: 552

Re: MPD not playing most (but not all) streams anymore

And: note that Raspi kernel 5.10 is known to be buggy. I don't know if yours is already fixed, but it might worth trying an older kernel.
See https://github.com/MusicPlayerDaemon/MPD/issues/1056
by max
February 28th, 2021, 1:41 pm
Forum: Help
Topic: MPD not playing most (but not all) streams anymore
Replies: 6
Views: 552

Re: MPD not playing most (but not all) streams anymore

I can play all of those streams. Post a verbose log of MPD, playing each stream. And read https://www.musicpd.org/help/
Note that you're not using an ALSA "hw" device. Doing that would reduce CPU usage and would improve quality.
by max
February 27th, 2021, 11:21 am
Forum: Help
Topic: how to fix the decoders plugin error
Replies: 4
Views: 431

Re: how to fix the decoders plugin error

Maybe my question wasn't phrased well. The decode libraries MPD uses say that those files are broken. I did not check, that's not my expertise. MPD doesn't decode anything, it relies on many external libraries for the job. And those libraries say the files are broken. Do you believe those files are ...
by max
February 26th, 2021, 7:34 am
Forum: Help
Topic: how to fix the decoders plugin error
Replies: 4
Views: 431

Re: how to fix the decoders plugin error

What makes you believe that MPD should be able to play those files?
by max
February 24th, 2021, 5:17 am
Forum: Help
Topic: How to get song info by URI
Replies: 3
Views: 1491

Re: How to get song info by URI

This is not a MPD response. I have no idea what it is, but apparently, you're not using MPD.
Other than that, read and obey https://www.musicpd.org/help/ (a requirement which you chose to ignore on IRC)
by max
February 23rd, 2021, 11:12 pm
Forum: Help
Topic: How to get song info by URI
Replies: 3
Views: 1491

Re: How to get song info by URI

Just use "lsinfo".

Code: Select all

lsinfo "music-lossless/Chris De Burgh/Spanish Train and Other Stories/10. Just Another Poor Boy - Chris de Burgh.flac"
by max
February 22nd, 2021, 11:49 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

No. This must never happen, this must be a bug in Meson. Or a buggy patch applied to Meson by the Yocto-Meson package. Consult Yocto support.
by max
February 22nd, 2021, 8:23 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

That's wrong. This violates Meson's documentation. How did this illegal value end up there?

See https://mesonbuild.com/Reference-tables ... stem-names
by max
February 22nd, 2021, 5:13 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

It checks for sqlite and libupnp: Run-time dependency sqlite3 found: YES 3.29.0 Run-time dependency libupnp found: YES 1.8.4 But between those two, it *should* check for libsystemd, but it doesn't. From the meson.build, there is exactly one reason why it would skip that check (and not even print a m...
by max
February 20th, 2021, 4:25 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

What does "mpd --version" print?
Does it show libsystemd being detected in the log.configure?
by max
February 20th, 2021, 12:05 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

Did you build MPD without libsystemd?
by max
February 20th, 2021, 7:49 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2263

Re: MPD >0.21 with yocto

Doesn't seem to do what trick? What is the remaining problem?
by max
February 18th, 2021, 4:26 pm
Forum: Help
Topic: help me troubleshoot - ALSA, MPD or USB preamp issue
Replies: 1
Views: 1002

Re: help me troubleshoot - ALSA, MPD or USB preamp issue

I don't think anybody here can help you. This problem has nothing to do with MPD. The kernel has decided that the sound device is gone - maybe because it thinks it has been unplugged. Check the kernel logs for details. Different programs can make a difference if you configured to access the hardware...
by max
February 18th, 2021, 7:51 am
Forum: General Discussion
Topic: Congrats Snapcast support
Replies: 1
Views: 1297

Re: Congrats Snapcast support

Even if it's still experimental - you're welcome to report problems like that Android problem on GitHub.
by max
February 17th, 2021, 11:05 pm
Forum: NCMPC
Topic: Exit when MPD shutdown
Replies: 1
Views: 2120

Re: Exit when MPD shutdown

No. Write bug report.