Search found 176 matches

by skidoo
March 9th, 2018, 11:15 pm
Forum: Help
Topic: radio stream do not start
Replies: 13
Views: 3388

Re: radio stream do not start

MPD from git (Debian testing x64 server located in western germany) all streams working - even truncated 1live stream.

Do you have problems connecting to stream or "dropouts" during play?
by skidoo
March 8th, 2018, 7:50 pm
Forum: Help
Topic: Bad radio station URL hanging MPD
Replies: 8
Views: 2206

Re: Bad radio station URL hanging MPD

Weird stream of death.. Today # mpd --stdout --no-daemon --verbose Mar 08 20:35 : client: [0] process command "load "mmsh://mediau.yle.fi/a_radiosavo?MSWMExt=.asf#YL"" ... and MPD needs to be killed with -9 option. client: [0] process command "load "mmsh://mediau.yle.fi/a_radiosavo?MSWMExt=.asf#YLE"...
by skidoo
March 7th, 2018, 10:04 pm
Forum: Help
Topic: Bad radio station URL hanging MPD
Replies: 8
Views: 2206

Re: Bad radio station URL hanging MPD

MPD from git with --enable-mms plays mmsh://mediau.yle.fi/a_radiosavo?MSWMExt=.asf#YLE (Debian testing, x64)

You may try to build MPD on your Raspberry https://www.musicpd.org/doc/user/install_source.html took less than an hour on my Banana Pi.
by skidoo
March 4th, 2018, 3:35 pm
Forum: Help
Topic: Mpd no sound when listening radio
Replies: 9
Views: 2039

Re: Mpd no sound when listening radio

“Nie dla wszystkich skrzypce grają” but I think with some effort your favorite stream should play in MPD ;) Does $ ffplay http://77.55.215.209:9000 work? Follow standard MPD debug procedure. https://www.musicpd.org/help/ Update to recent MPD (current is MPD 0.20.18) If your distribution comes with o...
by skidoo
March 3rd, 2018, 10:53 am
Forum: Help
Topic: Mpd no sound when listening radio
Replies: 9
Views: 2039

Re: Mpd no sound when listening radio

MPD (from git, ffmpeg 3.4.2, Debian testing x64) plays stream. BUT from time to time MPD refuses to play stream and mpd.log shows ffmpeg errors: Mar 03 11:22 : ffmpeg/aac: decode_band_types: Input buffer exhausted before END element found Mar 03 11:22 : ffmpeg: avcodec_send_packet() failed: Invalid ...
by skidoo
March 1st, 2018, 7:45 am
Forum: Help
Topic: Mpd no sound when listening radio
Replies: 9
Views: 2039

Re: Mpd no sound when listening radio

vlc says

core error: connection failed: Connection refused
http error: cannot connect to 77.55.215.209:9000
core error: connection failed: Connection refused
access_mms error: cannot connect to 77.55.215.209:9000
core error: open of `http://77.55.215.209:9000' failed
by skidoo
February 28th, 2018, 8:20 pm
Forum: Help
Topic: Mpd no sound when listening radio
Replies: 9
Views: 2039

Re: Mpd no sound when listening radio

http://77.55.215.209:9000 does not play in vlc.
by skidoo
January 28th, 2018, 1:43 pm
Forum: Help
Topic: radio stream do not start
Replies: 13
Views: 3388

Re: radio stream do not start

Not an MPD problem: https://www.di.fm/premium - Use External Players & Devices buy premium user account.
by skidoo
January 24th, 2018, 2:40 pm
Forum: Tips, Tricks, and Hacks
Topic: Synchronous multi room audio
Replies: 9
Views: 6024

Re: Synchronous multi room audio

MPD with synchronous multiroom and multiple zones? YES!
by skidoo
January 24th, 2018, 11:58 am
Forum: Tips, Tricks, and Hacks
Topic: Synchronous multi room audio
Replies: 9
Views: 6024

Re: Synchronous multi room audio

Yes it works but it is not perfect (yet ;) )

  • Snapcast plays music with "hickups" until all clocks are in sync.
  • There is not native MPD plugin for Snapcast. Changing volume and muting is delayed.
  • MPD does not support multiple audio outputs (yet). Therefore no support for Snapcast zones.
by skidoo
January 22nd, 2018, 3:06 pm
Forum: Help
Topic: mpd stops communicating with ALSA after system upgrade
Replies: 5
Views: 4803

Re: mpd stops communicating with ALSA after system upgrade

Debian and *bunutu create and set permissions for mpd user: check package for mpd.postinst file - no home directory required. MPD configuration file $ mpd --stdout --no-daemon --verbose /etc/mpd.conf @max> man mpd MPD searches for a config file in $XDG_CONFIG_HOME/mpd/mpd.conf then ~/.mpdconf then /...
by skidoo
January 20th, 2018, 7:04 pm
Forum: Help
Topic: mpd stops communicating with ALSA after system upgrade
Replies: 5
Views: 4803

Re: mpd stops communicating with ALSA after system upgrade

Debian and *buntu MPDs are ancient. Compile from source with package parameters as a starter. BTW: Pulseaudio installed? Your mpd.conf does not shoẃ a mixer device... Google for ALSA debugging.
by skidoo
January 13th, 2018, 2:27 pm
Forum: Help
Topic: radio stream do not start
Replies: 13
Views: 3388

Re: radio stream do not start

Stream URL? MPD version?
by skidoo
December 28th, 2017, 10:45 pm
Forum: Help
Topic: Splitting 3 soundcards for mpd
Replies: 11
Views: 2932

Re: Splitting 3 soundcards for mpd

@Max> MPD partitions are independ from each other. Kind of global or virtual "all" or "party" partition would be nice. Play source to all outputs and increase, decrease or mute volume on all outputs. I know X-mas is over ;) @ainawing> Maybe you should discuss your ideas with some whole house audio e...
by skidoo
December 23rd, 2017, 9:54 pm
Forum: General Discussion
Topic: Certificate expired
Replies: 1
Views: 1180

Certificate expired

www.musicpd.org -> 23rd of december 2017
forum.musicpd.org -> 25th of december 2017
by skidoo
December 20th, 2017, 8:42 pm
Forum: Help
Topic: Splitting 3 soundcards for mpd
Replies: 11
Views: 2932

Re: Splitting 3 soundcards for mpd

Solution depends on expected results. Please do not mix Pulseaudio and ALSA. Stay in the ALSA domain. One (1) source (MPD) distributed to multiple rooms. Mute for every single room is possible. Global volume control possible. Follow Max advice and configure multiple MPD audio outputs. Use only ONE s...
by skidoo
December 6th, 2017, 1:29 pm
Forum: Developers' Corner
Topic: Output plugin
Replies: 4
Views: 2281

Re: Output plugin

Check diz out viewtopic.php?f=9&t=3847&p=5666&hilit=rtp#p5666 - MPD pipe output into ffmpeg for RTP multicast. Is this what you are looking for?
by skidoo
October 27th, 2017, 11:15 am
Forum: General Discussion
Topic: Congradulations with mpd 0.20.x on Ubuntu 17.10
Replies: 9
Views: 3578

Re: Congradulations with mpd 0.20.x on Ubuntu 17.10

Denon's US$ 500 Ethernet cable episode is about eight to ten years in the past. They are back in the butter and bread hifi business. (Standard disclaimer: happy owner of a 30 year old Denon power amplifier.)

Thanks for keeping MPD free from bullshit / esoteric / voodoo related stuff.
by skidoo
October 26th, 2017, 10:13 pm
Forum: General Discussion
Topic: Congradulations with mpd 0.20.x on Ubuntu 17.10
Replies: 9
Views: 3578

Re: Congradulations with mpd 0.20.x on Ubuntu 17.10

With this thingy http://www.myhifishop.de/Devices/AQ-SWI ... anguage=en your ethernet cables will sound better than ever :D
by skidoo
October 25th, 2017, 4:00 pm
Forum: Help
Topic: Avahi 0.7 no service
Replies: 4
Views: 1927

Re: Avahi 0.7 no service

No - MPD started at boot or via

Code: Select all

systemclt start mpd
But it failed to register with Avahi. Quick fix was to use MPD (server) ip on the client computer.