Search found 7 matches

by NNEU
February 22nd, 2021, 8:27 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

I don't know ..
Any idea on how it could be fixed ?
by NNEU
February 22nd, 2021, 7:54 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

host_machine.system() returns "linux-gnueabi"...
by NNEU
February 20th, 2021, 5:47 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

Interesting. It doesn't show systemd amongst other features: mpd --version Music Player Daemon 0.22.7 (v0.22.6-2-g85427826a) Copyright 2003-2007 Warren Dukes <warren.dukes@gmail.com> Copyright 2008-2018 Max Kellermann <max.kellermann@gmail.com> This is free software; see the source for copying condi...
by NNEU
February 20th, 2021, 4:22 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

Here is the full recipe: SUMMARY = "Music Player Daemon" LICENSE = "GPLv2" LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" HOMEPAGE ="http://www.musicpd.org" inherit meson useradd systemd pkgconfig DEPENDS += " \ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ curl \ ...
by NNEU
February 20th, 2021, 12:12 pm
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

Ah, sorry forgot to mention.

No, I left systemd in the recipe. I only commented out the following line to get rid of the error.

#SYSTEMD_SERVICE_${PN} = "mpd.socket"
by NNEU
February 20th, 2021, 11:07 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

Re: MPD >0.21 with yocto

Two problems. I can't tell for sure if they are related to the mpd.socket, but im guessing so because its the only thing I changed. 1. MPD service starts after boot and then stops after some time without coming back. systemctl --user status mpd.service mpd.service - Music Player Daemon Loaded: loade...
by NNEU
February 20th, 2021, 2:24 am
Forum: Help
Topic: MPD >0.21 with yocto
Replies: 12
Views: 2076

MPD >0.21 with yocto

Hi! I'm trying to use MPD in the Yocto Project. MPD 0.20.22 is provided as a part of the OE layer, but since it is no longer supported I would like to update to a newer/the latest version. I looked at the patches that Max has submitted to OE and implemented them in the recipe, but the error "SYSTEMD...