Search found 6 matches

by langrock
May 20th, 2020, 4:41 pm
Forum: Help
Topic: MPD httpd Streaming issue
Replies: 9
Views: 1764

Re: MPD httpd Streaming issue

If you receive audio from port 8000, but not from ympd, then this is a ympd problem which I cannot help with. But I would seriously suggest not using streaming for your own personal use. That's up to you, of course. I am in the same boat as the original poster, but using the ympd fork myMPD instead...
by langrock
May 20th, 2020, 6:24 am
Forum: Help
Topic: Database persistence
Replies: 6
Views: 395

Re: Database persistence

Thanks for the explanation. I followed your advice and purged mpd and all of its dependencies and started fresh. The new sample configuration file looks much more detailed now with lots of helpful comments. I was able to recreate the settings from the old configuration file and update the database u...
by langrock
May 19th, 2020, 4:17 pm
Forum: Help
Topic: Database persistence
Replies: 6
Views: 395

Re: Database persistence

Thanks. While I most certainly didn't delete that file, I uninstalled MPD and did an autoremove of all associate packages before installing once more using sudo apt-get install mpd/stable-backports At the end of the installation, I get messages that already seem to indicate problems Setting up mpd (...
by langrock
May 19th, 2020, 7:35 am
Forum: Help
Topic: Database persistence
Replies: 6
Views: 395

Re: Database persistence

Thanks. The repository I was using (http://raspbian.raspberrypi.org) didn't have a more current version, so I followed the instructions on the 'Unofficial Debian packages' site to add the kaliko.me repo. It then installed the 0.21.22 version of MPD, which is much newer than the 0.21.5 I had before. ...
by langrock
May 18th, 2020, 5:00 pm
Forum: Help
Topic: Database persistence
Replies: 6
Views: 395

Database persistence

Hi, Sorry to trouble you again. It appears that the 'database' disappears once mpd restarts. My configuration is below. I am using an SMB share for the storage location of the music and a local file for the database. When I run 'mpc update', it appears that the database is being populated, but upon ...
by langrock
May 17th, 2020, 6:55 pm
Forum: Help
Topic: Connect to SMB client
Replies: 0
Views: 332

Connect to SMB client

Update: Figured it out after fiddling with it some more. The problem was the database entry, which pointed to the server. Using the "simple" plugin, and using a local file for the database and cache_directory, myMPD is now starting to populate the database from the SMB source! I had to run 'mpc upda...